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Chapter 1
Introduction

The PADS VX releases introduce a new PADS Integrated Project as an addition to the 
traditional PADS Designer netlist to PADS Layout, PADS Logic netlist to PADS Layout, and 
Third-party schematic netlist to PADS Layout projects. 

Integrated Project Overview and Benefits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Integrated Project Overview and Benefits
An integrated PADS Designer to PADS Layout project brings together the schematic and layout 
in an integrated database. The library and constraints are also central between the schematic and 
layout. This results in a number of benefits over traditional netlist projects including increased 
productivity.

Caution
Design migration can be performed only in one direction. Once you migrate your netlist 
project to an integrated project, there is no way to return it to a netlist project. Libraries 

converted to the integrated flow cannot be used for a netlist project.

Restriction
Formal Design Reuse is not supported in an Integrated flow project. While you can import a 
reuse block in ECO mode, there is no integration with a matching schematic reuse block. In 

the netlist flow there is some support with design reuse using the REUSE_BLOCK property for 
hierarchical blocks.

This information should help you to decide if the benefits exceed the migration effort and 
change to the way you work. Traditional PADS work-flows are fully supported. You do not 
need to commit to any particular project type. You can use the integrated project for some 
designs, and the netlist project for other designs. This flexibility is particularly useful for service 
bureaus, which receive design data from different sources. If you maintain your own libraries, 
this approach requires maintaining separate libraries for integrated and netlist projects.

The new Integrated Project is built on:

• An integrated database, which stores connectivity and constraint data for both schematic 
and layout, and provides a built-in synchronization mechanism.
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• An integrated Central Library, which:

o Provides unified storage of schematic symbols, part definitions, layout footprints, 
drawings, and analog simulation models.

o Maintains relations between the library elements.

o Is integrated with the Component Information system.

• A new spreadsheet-based constraint management environment, providing unified access 
to constraint data at both front and back ends.

• A new library management environment, providing unified access to library 
management and editing tools and ODBC-compatible component databases. Each 
integrated project is “attached” to a specific Central Library.

Benefits of an integrated project:

• Constraints can be edited and reviewed in a unified manner in schematic or in layout and 
changes can be propagated back and forth by clicking a button.

• The Constraint Manager cross-probes both with schematic and layout. 

• Length constraint violations can be reviewed inside the constraint management 
environment. 

• An interface is provided for automatic creation of differential pairs. 

• Spreadsheet-based constraint editing and reviewing are more convenient and provide 
better productivity compared to dialog based. 

• A built-in data synchronization mechanism between layout and schematic provides real 
time database synchronization status and makes the forward and backward annotation 
more reliable. Instead of comparing two independent databases, all changes are 
registered inside the integrated database as they occur.

• Library management is simplified with the unified interface and a single library to 
manage.

A PADS Integrated Central Library has a “part-centric” data model. A “part” is a key object 
describing a part (in the layout). It ties together schematic symbol(s) with layout footprints 
(decals) and stores the mapping between symbol pins and footprint pin numbers.

When you migrate libraries, it is important to understand that the Central Library (unlike PADS 
part libraries) allows only one instance of any part name. So the order of source libraries in the 
migration list of the Migrator tool is very important; once the Central Library Migrator creates a 
part name in the Central Library other parts with the same name are ignored. 

The Migrator tool accepts parts from these four sources:

• PADS Designer symbol libraries
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• PADS Designer Project symbol instances

• PADS Designer Databook files (.dbc files)

• PADS part libraries (.pt9 files)
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Chapter 2
Rules Differences and Migration

When you are considering migrating your existing designs to PADS Integrated projects, you 
need to closely consider design rules migration.

The design rules model used by PADS Integrated projects differs from the traditional PADS 
rules model. For most rules there is a direct mapping between traditional PADS rules and 
Integrated Project constraints, but some rules may be lost or altered.The following topics 
explain how rules are migrated, and list rules differences between Netlist projects and 
Integrated projects.

How Rules are Migrated . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Rules Differences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Electrical Net Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

How Rules are Migrated
When designs are migrated to an integrated PADS Designer project, they are stored in the 
Constraint Manager under a different structure.

In the rules migration:

• Net classes are converted to matching net classes in Constraint Manager.

• Some rules become constraints in the Constraint Classes section. These rules are 
assigned to individual nets. All nets belong to the one “(All)” constraint class.

• Trace width, layer biasing and via assignment rules are defined on the net class level.

• Clearance rules are specified in clearance sets (the Clearances section in Constraint 
Manager) as follows:

o Clearances specified for a net class appear in one of the clearance rule sets. This 
clearance rule set will be assigned to the Net Class/(All) pair in the Class to Class 
Clearance Rules table in Constraint Manager.

o Clearances specified on a particular layer (a conditional rule for the Class/Layer 
pair) are migrated to the same clearance set (just as clearance rule sets define 
clearance values for all layers).

o For a conditional clearance rule between two classes, a clearance set is created and 
assigned to the corresponding cell in the Class to Class Clearance Rules table. 
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Additional clearances specified on some layers are migrated to the same clearance 
rule set.

• For each clearance, trace width, layer biasing or via biasing rule specified on the net 
level, a net subclass is created containing one net, and the rule is assigned to that 
subclass. (See “Routing Rules Differences” on page 14 for a description of the 
difference between via biasing and via assignment.)

• Matched length groups (for nets and pin pairs) become constraints in the Constraints 
Classes section. The matched length group name can be found in the “Match” column. 
(In order to see pin pairs, they need to be expanded in the view from nets: 
View > Expand > All.)

• Topology, number of vias, stub length, min/max length rules become constraints in the 
Constraints Classes section.

• Component rules (Clearance, Via Assignment, Fanouts, Pad Entry) become accessible 
as follows: 

o Individual component rules are accessible using the Component Rules and Decal 
Rules buttons in the PADS Layout Component Properties dialog box.

o Default via, fanout, and pad entry rules are accessible using the Via Spans, Fanouts 
and Pad Entry selections in the PADS Layout Setup menu. (See “Routing Rules 
Differences” on page 14 for a description of the difference between via biasing and 
via assignment.)

• Body to body clearance becomes accessible in Constraint Manager via 
Edit > Clearances > General Clearance in Constraints Manager.

• Global clearance rules for test points and the maximum length of test point stubs become 
accessible in PADS Router via Options > Test Points.

• Differential pairs become constraints in the Constraint Classes section, as follows:

o Two nets are grouped together.

o Trace width and gap values are defined on the net class level in Constraint Manager.

o For each differential pair a net subclass is created to carry trace width and gap rules.

o Length rules for differential pairs become constraints in the Constraint Classes 
section.

o For other changes in differential pair rules, see the “Diff Pair Rules Differences” on 
page 13 topic. 

• Electrical nets and design rules migrate with potential exceptions. For more information, 
see “Electrical Net Migration” on page 14
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Rules Differences
When migrated, some rules have default values that cannot be changed, some are not migrated 
and others have single global values.

Unsupported Rules

The following netlist project rules are not supported in integrated projects.

• Pin Pair Clearance Rules

• Diff Pairs of Pin Pairs

• High Speed Rules: Parallelism, Tandem, Aggressor, Shield, Shielding Gap, Delay, 
Capacitance and Impedance, and Stub Length

Clearance Rules Differences

Diff Pair Rules Differences

Netlist Project Clearance Rule In Integrated Projects 

SMD to [Pad | SMD] Pad to [Pad | Pad] clearances are used.

Text to [Trace | Via | Pad | SMD] Trace to [Trace | Via | Pad | SMD] clearances 
are used.

Drill to [Trace | Via | Pad | SMD | Copper] Pad/Via to [Trace | Via | Pad | Pad | Trace] 
clearances are used.

Global Drill to Drill Clearances to pads (via or pin pads) are used.

Same Net [Pad | SMD | Trace] to Corner

Same Net [SMD | Via] to Via

General (non-same net) rules are used:

[Pad | SMD | Trace] to Trace

[SMD | Via] to Via

Netlist Project Clearance Rule In Integrated Projects - Replacement/
Default Value

Allow split around obstacles Uses the new Max Separation Distance rule.

Max number of obstacles

Max obstacle size

Restrict layer changes during autorouting Not supported for individual diff pairs. This is 
now a global setting for diff pairs in the 
Options > Routing > General category.
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Routing Rules Differences

Electrical Net Migration
There are differences in the management of electrical nets in netlist and integrated projects.

Major Differences

• Electrical nets in a netlist project exist only in PADS Layout or PADS Router, while 
electrical nets in integrated projects are set in the Constraint Manager.

• In netlist projects, discrete component (gate) length is defined on each component. In 
integrated projects, the discrete component length is defined on the part and all 
components sharing the same part type have the same discrete component length. 

• The recognition of multi-gate discrete packages is different. In netlist projects, discrete 
packs are multi-gate parts with no signal pins and all gates must be two-pin gates. In 
integrated projects, in the Constraint Manager, you must specify Discrete Component 
Pin Pairs for your part.

• In netlist projects you can create an electrical net going through a component with a 
refdes prefix that is not listed in the discrete component prefixes list. In integrated 

Netlist Project Clearance Rule In Integrated Projects 

Via Biasing Available vias in Via Assignment. In Via 
Biasing you specify a subset of vias that 
should be available for a particular net class. 
In Via Assignment you define one via for 
each via span. For example, there can be only 
one through-hole via specified for a net class.

Topology Topology - MST (minimized), Chained 
(serial), and Custom (protected)

Auto Route Enabled and cannot be modified.

Allow Unroute Enabled and cannot be modified.

Allow Shove Enabled and cannot be modified.

Allow Shove Protected Enabled and cannot be modified.

Copper Sharing (T-Junctions): Vias Does not migrate, but if the netlist project 
Stub Length setting in the High Speed Rules 
is equal to zero, Copper and Trace sharing is 
disabled in the integrated project. If the Stub 
Length setting is greater than zero, Copper 
and Trace sharing is enabled in the integrated 
flow.

Copper Sharing (T-Junctions): Traces
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projects, this is not possible and you can lose these kinds of electrical nets during 
migration.

Electrical Net Settings

When a netlist PCB design is associated with an integrated project, electrical net settings 
defined in the Setup > Electrical Nets dialog are copied to the front end Constraint Manager 
data. This triggers automatic recreation of electrical nets on the front end side with the updated 
settings. Created electrical nets are propagated to the back end Constraint Manager data during 
Forward Annotation.

“Maximum net count per electrical net” value is migrated to the Constraint 
Manager > Setup > Settings > Electrical Nets > Physical nets count per electrical net 
setting.

“Maximum non-plane-net pin count” value is migrated to the Constraint 
Manager > Setup > Settings > Electrical Nets > Pin count setting.

“Discrete component prefixes” table is copied to the Constraint 
Manager > Setup > Settings > Discrete Component Prefixes table.

Component Properties

In a netlist project, each component has three properties affecting electrical nets: 

• “Create electrical net” check box

• “Allow electrical net creation by refdes prefix and nets” check box

• “Discrete length”

If you want to prevent electrical nets going through this component, you must clear both check 
boxes. In this situation, the two properties are migrated to the single cleared check box of the 
Series setting for this component in the Constraint Manager. All other combinations of these 
two properties select the Series check box. In cases where “Create electrical net” is selected, 
there’s a risk of losing the electrical net going through this component because the Constraint 
Manager never creates electrical nets through components if the refdes prefix is missing in the 
Discrete Component Prefixes table.

Discrete length value is translated to the Pin Package Length constraint. For each pin, Pin 
Package Length = Discrete Length / 2. Since you cannot specify a discrete length for individual 
components, if different discrete values are detected on component that share the same part 
type, the migration process writes a warning message to the log file and uses the largest value 
found among the components using that particular part type.
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Net Properties

In a netlist project, each net has two properties affecting electrical nets:

• “Create electrical net” check box

• “Allow electrical net creation by components” check box

If you want to prevent a net from being included in an electrical net, you must clear both check 
boxes. In this situation, the two properties are migrated to the single selected check box of the 
Analog setting for the net in the Constraint Manager. All other combinations of these two 
properties clear the Analog check box. In cases where “Create electrical net” is selected, there’s 
a risk of losing the electrical net going through this component because the Constraint Manager 
never creates electrical nets through components if the refdes prefix is missing in the Discrete 
Component Prefixes table.

Discrete Packs

You can create electrical nets going through multi-pin components, such as resistor packs. In 
netlist projects, discrete packs are multi-gate parts with no signal pins and all gates must be two-
pin gates. In integrated projects, in the Constraint Manger you must specify Discrete 
Component Pin Pairs for your part. Nets attached to pins of a specified pin pair can be merged 
to create an electrical net. During the migration, Discrete Component Pin Pairs are created 
automatically for all parts that are recognized as discrete packs inside the netlist PCB design.

Differential Pairs and Design Rules

Differential pairs created from two electrical nets in the netlist PCB design are migrated to the 
back end Constraint Manager, replacing differential pairs defined in the front end Constraint 
Manager. Design rules associated with electrical nets and differential electrical nets are 
migrated to the back end Constraint Manager like design rules for regular nets and differential 
pairs.

Rules Migration Log File

The rules migration process writes messages into the RulesSynch.log file. The link to this log 
file is written to the Output Window. The RulesSynch.log file lives inside the integrated project 
folder and it accumulates messages related to migration of differential pairs, electrical nets, 
design rules and electrical net related Component and Net Properties.

Migrating Designs Without Electrical Nets

If you want to prevent migration of electrical nets and design rules defined inside the layout 
design, clear the “Preserve PCB design rules on first Forward Annotation” check box inside the 
Project Integration dialog before first running Forward Annotation. In this scenario, electrical 
nets defined in the front end Constraint Manager are annotated to the back end and all design 
rules inside the layout design are recreated from schematic constraints. 
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Chapter 3
Migrating PADS Designer Netlist Designs to

Integrated Projects

Perform the following procedures to migrate netlist designs created in the PADS Designer to 
integrated projects.

For information on how rules are migrated, see “Rules Differences and Migration”.

Procedure 1 — Prepare the Design(s) for Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Procedure 2 — Create a New Central Library . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Procedure 3 — Create the PADS Designer Integrated Project. . . . . . . . . . . . . . . . . . . . 21

Procedure 1 — Prepare the Design(s) for 
Migration

Before you can migrate a design, you must ensure that the layout and schematic are 
synchronized and that all layout parts are in PADS libraries.

Restrictions and Limitations

• You can specify only one PADS Designer project for a given migration run, so if you 
need to build a Central Library from local symbols scattered among several projects you 
need to run the migration process several times, specifying a new project file each time.

• If you’re using generic symbols (with no part information) and do not specify either an 
PADS Designer project file or PADS Databook as a Central Library part data source in 
the migration list, the symbols will be migrated but will have no association with Central 
Library parts.

• Hetero 2 and hetero 4 devices are not supported in the PADS Integrated Central Library. 
If you are using such devices you should not migrate to the PADS Integrated Project.

Caution
Design migration can be performed only in one direction. Once you migrate your netlist 
project to an integrated project, there is no way to return it to a netlist project. Libraries 

converted to the integrated flow cannot be used for a netlist project.

Prerequisites

• If you are not using generic symbols, and your symbol libraries contain part definitions, 
you need to add your symbol libraries to the migration list followed by PADS (.pt9) 
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libraries. In this case your Central Library parts and symbols will be created from 
symbols and Central Library decals will be created from PADS libraries. If you have 
multiple decal definitions with the same name in the PADS libraries, the decal first 
encountered will be associated with the Central Library part. 

• If you rely on part definitions in PADS libraries, you need to add PADS libraries first in 
the migration list, followed by your PADS Designer symbol libraries. In this case 
Central Library part definitions and decal associations will be created from PADS 
libraries and Central Library symbols will be created from the PADS Designer library 
symbols. If your PADS part definitions use pin mapping for alphanumeric pin numbers, 
the Migrator alters the decal name by adding the part type name as a suffix to the Central 
Library decal name. 

• If you are using generic symbols (this is typical for capacitors and resistors) in 
conjunction with the PADS Databook then you must add your PADS Databook files to 
the migration list, followed by PADS Designer symbol libraries and PADS libraries. In 
this case, Central Library part definitions and part-symbol associations will be taken 
from PADS Databook, Central Library symbols will be created from the PADS 
Designer library symbols and Central Library decals will be taken from the PADS 
libraries. 

• If you would like to use part definitions specific to your xDX project, you need to 
specify your project(.prj) file in the migration list as a source of part definitions. If the 
project is specified, it automatically adds to following items to the migration list: 

o The project itself

o Symbol libraries referenced by the PADS Designer project

o The PADS Databook file referenced by the PADS Designer project

In this case Central Library parts are created from the project symbol instances. 
Additional Central Library parts are created from local symbol libraries and from the 
local PADS Databook files. Central Library decal definitions are always built from the 
PADS libraries.

Procedure

1. Make certain that all parts and decals in the PADS Layout (.pcb) design are in libraries; 
if necessary, save the parts and decals to a new library, as described in “How to Save 
Library Decal and Part Definitions from a PADS PCB File”.

2. In PADS Layout, use the xDxDesigner link to synchronize the xDxDesigner .prj file 
with the PADS Layout .pcb file.

3. If you are not going to include local symbols in the migration, skip to Step 4; if you are 
going to include local symbols, continue with Step 3a.

a. In PADS Designer, open PADS Databook, and in the Symbol View select all local 
symbols (Shift+Select).
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b. In the popup menu choose Export and provide a folder for a symbol library.

c. Add the created libraries (each subfolder) to the list of libraries in Setup -> Settings -
> Symbol Libraries.

d. Select all local symbols.

e. Right-click > Substitute Symbols

4. In PADS Layout, run an integrity test (Modeless command “I”). If errors are found, 
resolve them.

5. In PADS Designer, run the PADS Designer Diagnostic. (Tools menu > PADS Designer 
Diagnostics). If errors are found, resolve them.

6. Ensure that Partition aliases correctly point to libraries that are referenced by the project.

7. Repeat this procedure on any other designs that will use the new Central Library.

8. Proceed to “Procedure 2 — Create a New Central Library” on page 19

Procedure 2 — Create a New Central Library
You must create a Central Library for the new integrated project(s) and add to it any required 
PADS libraries for the design.

Procedure

1. Start menu > All Programs > PADS [version] > Data and Library Management > 
Central Library Migrator

2. Create a folder for the new PADS Integrated Library:

a. In the PADS Unmanaged Libraries to Central Library Translator dialog box, click 
File > New PADS Integrated Library.

b. In the Browse For Folder dialog box, browse to the folder where you want to create 
the new library, or click Make New Folder to create and name a new folder for the 
library.

c. Select the folder and click OK.

3. Add PADS libraries for all designs you are migrating as follows:

a. Click the Add Libraries button, browse to the location of a design’s PADS libraries, 
select the libraries (.pt9 files) you want to migrate, and click OPEN.

b. If you want to add the libraries of another design, return to Step 3.a; otherwise, 
continue with Step 4.

4. [ Optional ] Add PADS Designer .prj files. Do this if any of the following is true:

• The project contains any symbol used by more than one part.
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• You want to add symbol or PADS Databook libraries from the PADS Designer 
project to the new integrated library.

Note
The partition names for symbol and PADS Databook libraries added with the 
project cannot be modified. Aliases that have been set for a library in PADS 

Designer are later used (during the Packaging) as a pointer to the location of the 
symbol in the Central Library. If these aliases are incorrect, the Packager will fail. 

• You want to do one or both of the following:

—Use the attribute mapping configuration file from the PADS Designer netlist 
project file (*.cfg) to map attributes (properties) to PADS integrated central library 
properties (in the CentLib.prp file, or

—Add PADS Designer netlist properties defined in the .cfg file to the new central 
library properties file (CentLib.prp).

Tip
For these purposes, the project file can be a dummy project used only to point to 
a configuration file.

Add PADS Designer project files as follows:

a. Click the Browse button to select an PADS Designer project (.prj) file and add the 
file and its symbol libraries and/or PADS Databook to the Library list.

b. In the Library List, set the added project’s check box as follows:

i. Select the check box to migrate the parts belonging to the project and/or to 
ensure a correct association of parts from the project with symbols from libraries 
in the new Central Library.

ii. Clear the check box if the parts in the project are not needed, or already belong to 
PADS libraries and are referenced in symbol libraries.

c. If an PADS Databook was added with the project, check its check box.

d. Set the “Create parts in single project partition” check box as follows:

i. Select the check box to create part objects in a central library partition defined by 
the PADS Designer project filename.

ii. Clear the check box to create part objects in central library partitions defined by 
the Partition property in the PADS Designer project file.

5. [ Optional ] Click the Add Symbols button to select a PADS Designer library parent 
folder and add the PADS Designer symbols to the Library list. You can modify the 
partition names, but the names cannot contain the following characters:

! \ " # $ % & ' ( ) * + , . / : ; < = > ? @ [ \ ] ^ ` { | } ~ )
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Repeat Step 5 if you want to add more symbol libraries.

6. [ Optional ] Click the Add PADS Databook button to select an PADS Databook .dbc 
file and add it to the Library list.

Repeat Step 6 if you want to add another PADS Databook .dbc file.

7. Prepare the Library List for migration, as follows:

a. Verify that the migration list is correct: check the list items you want to migrate, and 
uncheck the items you do not want to migrate.

b. If necessary, use the Move up and Move down buttons to reorder the list. Note that:

o If the project has alphanumeric parts, PADS libraries must be at the top of the 
list.

o List items are migrated in succession from top to bottom; since the Central 
Library cannot contain more than one instance of a part name, if the Translator 
encounters a part name it has already migrated from a previous library, that part 
is not migrated.

8. Click the Migrate button. When the migration completes, check the displayed log for 
errors. Information and warnings can also be useful in resolving problems.

9. Proceed to “Procedure 3 — Create the PADS Designer Integrated Project” on page 21

Procedure 3 — Create the PADS Designer 
Integrated Project

Create the .prj file for the new integrated project from the old netlist project .prj file.

Note
If you are migrating multiple designs that will use a single Central Library, perform this 
procedure for each of those designs.

Procedure

1. In PADS Designer, click File > New > Project.

2. In the New Project dialog box:

a. Select the Integrated Flow default template in the Project Templates tree.

b. Specify the new project’s name and location.

c. Specify the location of the Central library you just created, and click OK .

3. Import the netlist project, as follows:

a. Click File > Import > Netlist Project and select the netlist project file.
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b. In the Open Blocks dialog box, select all blocks and click Open.When the import 
completes, review the results in the Output Window.

4. If the Navigator window is not open click View menu > Navigator to open it. 

5. In the Navigator window tree, right-click the main block under the Blocks branch, then 
click Create Board.

6. In the Navigator tree, click on the new board.

7. Proceed to “Packaging the PADS Designer Project” on page 32
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Chapter 4
Migrating PADS Logic Designs to Integrated

Projects

Perform the following procedures to migrate designs created in PADS Logic to integrated 
PADS Designer projects.

For information on how rules are migrated, see “Rules Differences and Migration”.

Procedure 1 — Prepare the PADS Logic Design(s) for Migration . . . . . . . . . . . . . . . . . 23

Procedure 2 — Create an Integrated Project Central Library. . . . . . . . . . . . . . . . . . . . 24

Procedure 3 — Create a PADS Designer Integrated Project  . . . . . . . . . . . . . . . . . . . . . 24

Procedure 4 — Migrate a PADS Library to a PADS Integrated Central Library . . . . 25

Procedure 1 — Prepare the PADS Logic 
Design(s) for Migration

Before you can migrate a design, you must ensure that the layout and schematic are 
synchronized and that all layout parts are in PADS libraries.

Prerequisites

• If you are using parts with alphanumeric pin numbers defined on the part type level (pin 
mapping in the part type definition) the Migrator alters the decal name by adding the 
part type name as a suffix to the Central Library decal name. So if you want to avoid this 
renaming you should eliminate the use of the pin mapping mechanism before migrating 
your library.

Procedure

1. Make certain that all parts and decals in the PADS Layout (.pcb) design are in libraries; 
if necessary, save the parts and decals to a new library, as described in “How to Save 
Library Decal and Part Definitions from a PADS PCB File”.

2. In PADS Logic, use the PADS Layout link to synchronize the PADS Logic .sch file with 
the PADS Layout .pcb file.

3. In PADS Layout, run an integrity test (Modeless command “I”). If errors are found, 
resolve them.

4. Repeat this procedure on any other designs that will use the new Central Library.

5. Proceed to “Procedure 2 — Create an Integrated Project Central Library” on page 24
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Procedure 2 — Create an Integrated Project 
Central Library

You need a Central Library for the new integrated project(s).

Note
If you want to use an existing PADS Integrated Central Library please skip this procedure.

Procedure

1. Start menu > All Programs > PADS <version> (32-bit) > Data and Library 
Management > Central Library Migrator <version>

2. In the "PADS Unmanaged Libraries to Central Library Translator" window, click File > 
New PADS Integrated Library.

3. In the Browse for Folder dialog box, browse to an empty folder where you want to 
create the new library, or click Make New Folder to create and name a new folder for the 
library.

4. Your Central Library is now created in the folder you specified and you can close the 
"PADS Unmanaged Libraries to Central Library Translator" window.

5. To migrate more designs and libraries to this Central Library at a later time, open the 
library again with the File > Open Library command in the PADS Unmanaged 
Libraries to Central Library Translator dialog box.

6. Proceed to “Procedure 3 — Create a PADS Designer Integrated Project” on page 24

Procedure 3 — Create a PADS Designer 
Integrated Project

Create the .prj file for the integrated project from the PADS Logic .sch file.

Procedure

1. In PADS Designer, click File > New > Project.

2. In the New Project dialog box:

a. Select the Integrated Flow default template in the Project Templates tree.

b. Specify the new project’s name and location.

c. Specify the location of the Central library you just created, and click OK.

3. Import the PAD Logic schematic, as follows:

a. File > Import > PADS
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b. Click the Add button and add an.sch file that you want to translate

c. Click Translate and wait until the migration is finished.

d. Review the Translation Results to make sure there are no errors.

4. You can now close the Translation Results and Symbol and Schematic Translator 
windows. This populates the PADS Designer project with the schematic sheets created 
from the PADS Logic design and adds the symbol from the schematic to the central 
library.

5. “Procedure 4 — Migrate a PADS Library to a PADS Integrated Central Library” on 
page 25

Procedure 4 — Migrate a PADS Library to a 
PADS Integrated Central Library

When you imported the PADS Logic schematic into the PADS Designer integrated project in 
the previous step, symbols from the schematic were added to your central library, but you still 
need to migrate remaining library items, especially decals.

Procedure

1. Start menu > All Programs > PADS <version> (32-bit) > Data and Library 
Management > Central Library Migrator <version>

2. In the "PADS Unmanaged Libraries to Central Library Translator" window, click File> 
Open Library.

3. Browse for the location of the Central library used in previous procedures and click 
Open.

4. Add PADS libraries for the design you are migrating as follows:

a. Click the Add Libraries button, browse to the location of the design's PADS 
libraries, select the libraries (.pt9 files) you want to migrate, and click Open.

b. [Optional] You can modify the partition names, but the names cannot contain the 
following characters: 
! "%&*()/\?.,+-[]:<>| 
The list of prohibited characters is taken from the .cnv configuration file. The 
plogic_dx_migrator.cnv is used by default, but you can browse and choose another 
.cnv file
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5. [Optional] Add a dummy PADS Designer .prj file that only references a .cfg file. Do 
this if you want to do either or both of the following:

• Use the attribute mapping configuration file from the PADS Designer netlist project 
file (*.cfg) to map attributes (properties) to PADS integrated central library 
properties (in the CentLib.prp file, or

• Add PADS Designer netlist properties defined in the .cfg file to the new central 
library properties file (CentLib.prp).

Add the dummy .prj file to the library list as follows:

a. If necessary, create the dummy .prj file:

i. Start menu > All Programs > Mentor Graphics PCB > PADS <version> > 
Design Entry> PADS Designer

ii. File > New > Project

iii. In the New Project dialog box, click Netlist > default, type a name for the 
dummy project in the Name edit box, and click OK.

iv. In the Navigator window at the left, click on the project you just created, then 
click Setup > Settings.

v. In the Settings dialog box, make sure that the Use Custom Configuration File 
checkbox is checked, and that the file path listed is %SDD_HOME%/standard/
pads100.cfg.

vi. Click OK. The pathname of the new .prj file is listed in the PADS Designer 
window Start Page.

b. In the "PADS Unmanaged Libraries to Central Library Translator" dialog box, click 
the Browse button to select the project (.prj) file you just created and add it to the 
file to the Library list.

6. Prepare the Library List for migration, as follows:

a. Verify that the migration list is correct: select the list items you want to migrate, and 
clear the items you do not want to migrate.

b. If necessary, use the Move up and Move down buttons to reorder the list. The list 
items are migrated in succession from top to bottom; since the Central Library 
cannot contain more than one instance of a part name, if the Translator encounters a 
part name it has already migrated from a previous library, that part is not migrated.

c. The Central Library stores the Properties (Attributes) definitions. If you want your 
library attributes preserved you must select the “Add attributes to Property 
Definition File” check box.

7. Click the Migrate button. When the migration completes, check the displayed log for 
errors. Information and warnings can also be useful in resolving problems.
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The Central Library Migrator converts:

• PADS Logic CAE Decals to Central Library symbols

• PADS Part Types to Central Library parts

• PADS Decals to Central Library Decals

• PADS Drawings to Central Library Drawings

Existing relations between CAE Decals, Part Types and Decals are retained.

8. Proceed to “Packaging the PADS Designer Project” on page 32
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Migrating Third-Party Schematic Designs to 
PADS Designer Integrated Projects

You can migrate OrCAD, Altium, P-CAD and CADStar designs to PADS Designer integrated 
projects.

Procedure

1. Start menu > All Programs > PADS <version> (32-bit) > Data and Library 
Management > Central Library Migrator <version>

2. In the "PADS Unmanaged Libraries to Central Library Translator" window, click File > 
New PADS Integrated Library.

3. In the Browse for Folder dialog box, browse to an empty folder where you want to 
create the new library, or click Make New Folder to create and name a new folder for the 
library.

4. Your Central Library is now created in the folder you specified. Close the "PADS 
Unmanaged Libraries to Central Library Translator" window.

5. In PADS Designer, click File > New > Project.

6. In the New Project dialog box:

a. Select the Integrated Flow default template in the Project Templates tree.

b. Specify the new project’s name and location.

c. Specify the location of the Central library you just created, and click OK.

7. File > Import > (choose the Third-Party tool) and use the translator to bring the 
libraries and design into the PADS Designer project. 

8. Proceed to follow the instructions in“Procedure 4 — Migrate a PADS Library to a 
PADS Integrated Central Library” on page 25
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Chapter 6
Common Migration Procedures

The following topics are common to all the migration paths.

How to Save Library Decal and Part Definitions from a PADS PCB File . . . . . . . . . . . 31

Packaging the PADS Designer Project  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Associating the PADS Designer and PADS Layout Files . . . . . . . . . . . . . . . . . . . . . . . . . 32

Migration-Related Technotes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

How to Save Library Decal and Part Definitions 
from a PADS PCB File

You can save all parts and decals in a PADS Layout netlist flow design to a new library.

Procedure

1. Open the design in PADS Layout.

2. Click File menu > Library.

3. In the Library Manager dialog box, click the Create New Lib button.

4. In the New Library dialog box, enter a name for the new library and click Save.

5. Close the Library Manager dialog box.

6. Type Ctrl-Alt-F.

7. In the Selection dialog box, click the Nothing button, select the Parts check box, and 
click the Close button.

8. Type Ctrl-A to select all the parts.

9. Right-click > Save to Library.

10. In the Save Part Types to Library dialog box, select all the part types and decals, choose 
the new library you just created from the Part Type Library and Decals Library drop 
down lists, and click OK.

Results

All parts and decals in the design are saved to the new library.
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Packaging the PADS Designer Project
As a verification step, attempt to package the design – the packager used for PADS integrated 
projects is strict and it catches a lot of mismatches between schematic and library data.

Procedure

1. If not started, start PADS Designer and open your integrated project

2. Click Tools > Package

3. In the Packager dialog box, click the "Delete local data, then rebuild all local library 
data" option, and click OK.

4. When the Packager operation completes, resolve any Packager errors. If you have 
alphanumeric parts, you will see errors of this type: 

ERROR: Block CorporateDemo, Page Control_Buffers, Symbol $4I131: 
Cell Name 'LEDR_A' is not a valid cell for Part Number 

'LEDKA'.
 

This is because, in the migration, a new decal with a different name is created in the 
Central Library for each alphanumeric part. To fix these errors, in the new Central 
Library, either delete the "Cell Name" value for each of these parts, or update it with the 
name from the Central Library.

5. Close PADS Designer.

6. Proceed to “Associating the PADS Designer and PADS Layout Files” on page 32

Associating the PADS Designer and PADS 
Layout Files

In PADS Layout, specify the PADS Designer project to integrate with the layout design.

Restrictions and Limitations

For PADS Logic migrations — The "\" character is an illegal character in PADS Designer and 
the conversion of a Logic Schematic to DxD schematic replaces "\" characters to the "~" 
character. So, to sync your PCB, before associating with the project, you need to replace "\" 
with the "~" in net names using the PADS Layout ECO Rename Net command. For more 
information, see the TechNote https://support.mentor.com/en/knowledge-base/MG590026

Procedure

1. Copy the .pcb file of the netlist design you are migrating to the new integrated project 
folder you created in Step 2 of Procedure 4 — Migrate a PADS Library to a PADS 
Integrated Central Library.

https://support.mentor.com/en/knowledge-base/MG590026
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2. In PADS Layout, open the new copy of the .pcb file.

3. Click Setup menu > Project Integration.

4. In the Project Integration dialog box, click the Browse button, select the new.prj file you 
just created, and click Open.

5. In the Board Selection dialog box, select the main board and click OK.

6. [ Optional ] If you want to preserve the PCB electrical nets and design rules, select the 
“Preserve PCB design rules on first Forward Annotation” check box.

On forward annotation, electrical net settings are copied from the PADS Layout file to 
the Designer Constraint Manager. Electrical nets are recreated by the Designer 
Constraint Manager using the updated settings. Newly created electrical nets as well as 
electrical net settings are copied to the PADS Layout Constraint Manager database. 
Next, electrical net differential pairs and design rules associated with electrical nets are 
migrated. This creates constraints in the PADS Layout Constraint Manager database. 
This action can recreate electrical nets (if component properties Series and/or net 
properties Analog were changed during the migration of Component and Net 
Properties). Finally, electrical nets are propagated from the PADS Layout Constraint 
Manager to the PCB file. For more details, see “Electrical Net Migration” on page 14

7. Click the amber Forward Annotation Required, connectivity changed button.

8. Check the Output Window in PADS Layout for progress and results information. 
Migration to the integrated project is complete.

9. [ Optional ] Run Back Annotation to propagate migrated back end constraints to the 
front end.

Migration-Related Technotes
A list of Technotes to help with troubleshooting issues in migrated projects.

Support Center Technotes

Tech Note ID Problem

MG585929 PADS/PADS Designer: How to modify pin names on an established part in 
the PADS Library Tools (Integrated Project

MG585932 PADS Designer: Cannot open PADS library tools from PADS Designer 
(Integrated Project)

MG585934 PADS: White grid display when viewing symbols in PADS Library Tools 
(Integrated Project)

MG585969 PADS Designer: Package error: The required symbol is not in the Parts 
Database (Integrated Project)

https://support.mentor.com/en/knowledge-base/mg585929
https://support.mentor.com/en/knowledge-base/mg585932
https://support.mentor.com/en/knowledge-base/mg585934
https://support.mentor.com/en/knowledge-base/mg585969
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MG585971 PADS Designer: Packager shows errors about incorrect cell names 
(Integrated Project)

MG585972 PADS: Property <property name> is not defined and will not be added to part 
(Integrated Project)

MG585973 PADS Library Migrator: Heterogeneous part type II and IV is not supported 
(Integrated Project)

MG585974 PADS Central Library Migrator: Central Library partition already contains 
part. (Integrated Project)

MG585975 PADS Central Library Migrator: Symbol can't be associated with part. 
Duplicated pin numbers found (Integrated Project)

MG585976 PADS Central Library Migrator: Could not find pin decal (Integrated Project)

MG586006 PADS: Design Statistics Generation Failed when using Remote Desktop 
(Integrated Project)

MG590026 PADS: Negated nets are unrouted on first synchronization of migrated Logic/
Layout project to PADS Designer/Layout Integrated project

Tech Note ID Problem

https://support.mentor.com/en/knowledge-base/mg585971
https://support.mentor.com/en/knowledge-base/mg585972
https://support.mentor.com/en/knowledge-base/mg585973
https://support.mentor.com/en/knowledge-base/mg585974
https://support.mentor.com/en/knowledge-base/mg585975
https://support.mentor.com/en/knowledge-base/mg585976
https://support.mentor.com/en/knowledge-base/mg586006
https://support.mentor.com/en/knowledge-base/MG590026
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